Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D600 w/ New Shutter

NorthBay

Janesville, US
74 posts

Click to send email to this author Click to send private message to this author
NorthBay Gold Member Nikonian since 01st Jan 2013
Sun 17-Aug-14 02:40 PM | edited Sun 17-Aug-14 02:44 PM by NorthBay

I just got my D600 back from the free shutter assembly replacement. It took just over a week, which was pretty good. There were two surprises, however. As soon as I got it, I popped on a lens and took a f/22 flash shot of a white ceiling. (The ceiling is textured, which is why it isn’t a pure, uniform colour.) There was a prominent dust particle (circled in red) on the sensor. It wouldn’t budge with the rocket air blower, but disappeared after a wet cleaning. That’s not what I expected for something fresh out of Nikon service.

I also noticed several of my menu settings had changed. That wasn’t a big problem, since I keep a record of my settings. But it would have been simpler to “Save User Settings” before I pulled the memory card, and then do a restore after. Most Nikonians probably knew that, but for those who don’t, always save your settings before sending a camera body in for service.


Click on image to view larger version


Attachment#1 (jpg file)

TJ McCarthy
WarAxe Photography

Visit my Nikonians gallery.

G