Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

FT-1 problem solved-Needs Firmware 1.10 and up


High Springs , FL, US
1473 posts

Click to send email to this author Click to send private message to this authorClick to send message via AOL IM
tgreenwald Registered since 12th Dec 2005
Thu 20-Dec-12 07:44 PM

Just a heads up for someone who might experience this issue. My newly arrived FT-1 would not work on my V1. I read the directions and it said that you need Firmware A/B 1.10. My camera had 1.00.

Upgrading was not easy and I could not do it on a Mac running OS 10.8 at all. I could not copy the bin file to the In camera formated SD card-I tried from the internal SD card reader on my MacBook Pro as well as an external card reader.

I booted up my Sony Viao with Windows 7 and again I could not get the bin file to transfer to the SD card reader on the laptop but I was able to open the downloaded file and drop and drag the bin file on the SD card that was on an external card reader.

FT-1 works great and the focus is killer.

Hope this helps someone else.

This was the hardest firmware update I have done yet with Nikon.