Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Has anyone used the ML-L3 remote with the D7000?

RWA0655

US
9 posts

Click to send email to this author Click to send private message to this author
RWA0655 Registered since 15th Nov 2010
Mon 22-Nov-10 04:37 AM

I tried using my ML-L3 today with the D7000 and suspect that I am doing something wrong. I found that in both immediate and mirror delay modes, I needed to partially depress the shutter button to get the camera to focus before I used the remote. The camera would not focus before shooting when I used the remote.

I also found that in mirror-up mode the camera would sometimes fire the shutter once or twice instead of simply raising the mirror in anticipation of the next button press to activate the shutter.

I re-read all of the relevant sections in the manual, but haven't yet figured out what I'm doing wrong. Could anyone offer any suggestions?

Visit my Nikonians gallery.

Subject
ID
Reply message RE: Has anyone used the ML-L3 remote with the D7000?
1
Reply message RE: Has anyone used the ML-L3 remote with the D7000?
2
Reply message RE: Has anyone used the ML-L3 remote with the D7000?
3
Reply message RE: Has anyone used the ML-L3 remote with the D7000?
5
Reply message RE: Has anyone used the ML-L3 remote with the D7000?
4

G