Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
expat

Qawra St Pauls Bay, MT
532 posts

Click to send email to this author Click to send private message to this author
expat Silver Member Nikonian since 09th Mar 2010
Fri 27-Sep-13 04:04 PM | edited Fri 27-Sep-13 04:04 PM by expat

I know there is history on this but did anyone get to the bottom of it?

D700 latest FW
MB-D10 Grip (Genuine & new in that it has not been used before today when I decided to try AAs in it)works fine with the standard Nikon batteries but does not see the grip if AAs & their carrier are fitted.
Tried brand new HR6 & then LR6 with specs as specified in the MB-10 manual.

Have selected the appropriate battery in the camera menu and selected MB-10 to be used first but with the AAs it will only work from the camera body.

Maybe the internal contacts of the AA carrier but that's not easy to check.
Thanks for looking

Visit my Nikonians gallery.

Subject
ID
Reply message RE: AA Batteries
1
Reply message RE: AA Batteries
2
     Reply message RE: AA Batteries
3
          Reply message RE: AA Batteries
4
               Reply message RE: AA Batteries
5
                    Reply message RE: AA Batteries
6
                         Reply message RE: AA Batteries
7
                              Reply message RE: AA Batteries
8
                                   Reply message RE: AA Batteries
9
                                        Reply message RE: AA Batteries
10

G