Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

back monitor went blank

morpsmom_2

Weatherford, US
134 posts

Click to send email to this author Click to send private message to this author
morpsmom_2 Registered since 14th Jan 2005
Mon 29-Sep-08 05:28 AM

I had been shooting a bridal for about two and a half hours. I showed the "bride" the last picture before we did the couples pictures. Right after that, the monitor on the back of the camera went blank. I couldn't bring up any of the pictures to look at or the menu. I thought I might be able to see if I somehow switched something and that was why I couldn't see the pictures any more. Yet, I couldn't see the menu either. I checked the battery setting on the top. I had used about 1/4 of the battery, so that wasn't it. I tried turning it off and turning it back on. That didn't work. I had my D300 there, so I switched to it because I was using off camera flashes and needed to see if my exposure was correct. When I got home, I tried to access the pictures again and still had a blank screen. I downloaded the pictures. There was nothing wrong there. I will try recharging the batteries and see if that fixes it; although, I could still read the top of the camera. Any suggestions? This is only the fourth time I've used this camera.

G