Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

New Epson 3880 problems

gpoole

Farmington Hills, US
4122 posts

Click to send email to this author Click to send private message to this author
gpoole Platinum Member Fellow Ribbon awarded for his excellent and frequent contributions and sharing his in-depth knowledge and experience with the community in the Nikonians spirit. Awarded for his very generous support to the Fundrasing Campaing 2014 Writer Ribbon awarded for his article contributions for the Articles library and the eZine Nikonian since 14th Feb 2004
Wed 05-Dec-12 12:27 AM | edited Wed 05-Dec-12 12:31 AM by gpoole

I just received a new Epson 3880 printer today. This is my first attempt to print my own images. While trying to get my first prints, I've come up with the following problems/questions:


  1. I'm getting banding when using matte black ink but not with photo black ink. The bands are about 3/16" (5mm) wide and go from top to bottom of a landscape image with a lot of dark colors. I can't see any banding with a image of all pastel colors.

    • I ran Clean by holding the Menu button down for 3 seconds but that did not help. I can't remember which black cartridge was selected when I did the clean.

    • I ran an alignment check with matte black selected. It looked fine.

    • I also ran a nozzle check from the utilities with the matte black selected. It looked fine too and didn't go on to the auto clean.

    • I removed all the black cartridges and gave then a good shake. I shook them before I installed them too.

    None of these steps fixed the banding problem. I've run out of my supply of photo quality paper, so all I have until tomorrow is normal 20 lb copy paper. I can't duplicate the banding now, but I don't know if the banding has gone away because of use and all the things I've done or if the lower ink volumes for plain paper hide the problem.

  2. I'm printing from Capture NX2 in Windows 7 64. I've set the driver Mode to Off and I'm selecting the printer profile in CNX2. I started with PK selected, selected the Epson Premium Glossy profile, and printed. When changing to Premium Luster, Standard, or Archival Matte the black stayed at PK for the prints. I thought the profile would select PK or MK as appropriate for the profile. It looks like I need to make that selection manually. Is that correct?

  3. If I have to select between PK or MK manually, do I have to also make the other selections in the Media Settings like Media Type, Color vs. B&W, and Print Quality too?


For reference here is the image that I'm having the problems with. Click on the image to see a larger one.
Click on image to view larger version

Gary in SE Michigan, USA.
Nikonians membership - My most important photographic investment, after the camera.
D4, D810, D300 (720nm IR conversion), D90, F6, FM3a (black), FM2n (chrome)
YashicaMat 124, Graflex Speed Graphic 4x5
My Nikonians Gallery & Our Chapter Gallery

Subject
ID
Reply message RE: New Epson 3880 problems
1
Reply message RE: New Epson 3880 problems
2
Reply message RE: New Epson 3880 problems
6
Reply message RE: New Epson 3880 problems
3
Reply message RE: New Epson 3880 problems
4
Reply message RE: New Epson 3880 problems
5
     Reply message RE: New Epson 3880 problems
9
Reply message RE: New Epson 3880 problems
7
Reply message RE: New Epson 3880 problems
8
Reply message RE: New Epson 3880 problems
10
     Reply message RE: New Epson 3880 problems
11
          Reply message RE: New Epson 3880 problems
12

G