Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Epson R1800: strange problem (blank pages)


San Francisco, US
94 posts

Click to send email to this author Click to send private message to this author
Brodstein Silver Member Donor Ribbon awarded for his generous support to the Fundraising Campaign 2014 Nikonian since 03rd May 2007
Thu 12-Apr-12 03:13 AM

I have had my Epson R1800 since 2005, so I am pretty familiar with it (currently I am using it on my Mac Mini running OSX 10.6.8, Photoshop CS5, and the latest Epson driver).

Today I tried printing an 8.5 X 11 inch print, using paper of that dimension, and in the Print Settings dialog box, I selected "US Letter" as the Paper Size. Twice the print came out completely blank!

I then tried to print exactly the same image, but this time I put in 13 X 19 inch paper, and selected Super B (13 X 19 inch) as the Paper Size in the Print Settings dialog box. I realized that I would be wasting paper, but I wanted to isolate the problem. Lo and behold, the print came out fine, with large white borders, which I had anticipated.

I am flummoxed.

Any help would be greatly appreciated.

Thank you!