Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Fuji S3 problems; - DTTL, focus, AFAssist illuminator

ryszard


4 posts

Click to send email to this author Click to send private message to this author
ryszard Registered since 01st Nov 2005
Sat 08-Jul-06 11:58 AM

When using the S3's own built in flash with DTTL the exposures are totally accurate. However, when I put a Nikon SB28DX on it, the exposures are at least 2 stops underexposed. If I put +1 on the camera and +1 on the flash, I get a just about OK exposure but cannot choose to get any more light out of the flash, and it seems using the AUTO flash, (1960's technology) gives me better results.
Does anyone out there have the same experience or know if this is typical or any way round it?
Also, when I choose to put on the AF assist illuminator, sometimes it does not come on.
Also, ocassionally the auto focus does not work and I have to put the camera off and on to get it to work.
I'm doing more and more professional work these days and wish I'd bought a Nikon ! Toys are for children, so maybe fuji are marketing their cameras at babies !

Subject
ID
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
1
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
2
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
3
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
4
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
5
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
6
Reply message RE: Fuji S3 problems; - DTTL, focus, AFAssist illumina
7

G