Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300/MB-D10 grip controls not working

NRVVA

New River Valley, US
793 posts

Click to send email to this author Click to send private message to this author
NRVVA Gold Member Nikonian since 30th Jan 2013
Thu 07-Nov-13 11:39 PM

I installed an MB-D10 grip on my D300 and the main command dial, sub-command dial, and the multi selector controls on the grip do not respond. The shutter release and af button on the grip DO respond.

The batteries, one in the camera and one in the grip, are fully charged, the control lock switch on the MB-D10 is in the unlock position, the grip is securely and properly mounted to the camera base, and the contacts are clean. The battery sequence switch is set to the grip battery first, which is the default. I have searched through the menus trying to find some setting that I have overlooked, to no avail.

I have had the camera for a year and it functions flawlessly. The grip appears to be nearly brand new, with no signs of wear or even having been mounted on a camera.

I think I am overlooking a simple setting which would enable all of the grip's functions to respond properly. Any suggestions on what I am missing will be greatly appreciated.

Thanks!

Visit my Nikonians gallery.

Visit my Nikonians gallery.

Subject
ID
Reply message RE: D300/MB-D10 grip controls not working
1
Reply message RE: D300/MB-D10 grip controls not working
2
     Reply message RE: D300/MB-D10 grip controls not working
3
     Reply message RE: D300/MB-D10 grip controls not working
4
Reply message RE: D300/MB-D10 grip controls not working
5
Reply message RE: D300/MB-D10 grip controls not working
6
     Reply message RE: D300/MB-D10 grip controls not working
7
          Reply message RE: D300/MB-D10 grip controls not working
8

G