Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300s fires in continuous High drive at the same rate as in continuous low drive

EYEBALLER

Sterling Heights, US
102 posts

Click to send email to this author Click to send private message to this author
EYEBALLER Registered since 08th Sep 2011
Thu 10-May-12 04:05 AM

My brand new nikon D300s only shoots at the about the rate of 2fps for a top speed. It fires at exactly the same rate in both continuous high and continuous low speeds. I am using the optional Nikon battery grip with the optional E-4 lithium ion battery and it fires at the same rate as if I was only using the stock battery.Has anyone out there had this problem? I have been considering sending it back and getting my money back,because the only reason I purchased this was to be able to have the extra 1.5 reach by using a crop camera and use it for birding. I have a D700 and have been using it for birding along with the 300mm f/4 and a 1.4 tele convertor but want more reach.I have enjoyed the 8 fps using the optional grip and battery with my D700,but the specifications for the D300s also claim 8 fps using the optional battery grip and optional battery also,but I am not getting anywhere near that,it's running dog slow. I would appreciate any ideas anyone might have in regards to solving this problem.

Thank You in advance,

EYBALLER

EYEBALLER

Visit my Nikonians gallery.

G