Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
hokie

SAINT AUGUSTINE, US
16 posts

Click to send email to this author Click to send private message to this author
hokie Registered since 08th Oct 2007
Fri 07-Jan-11 06:48 PM

have been using a Zeikos Grip on my D300 for several months without any problems until about a month ago. Then, in the middle of some shooting, the mirror when up but the shutter would not fire. Finally pulled the batteries and the shutter reset, tried again...same results (with the grip removed)

Sent the camera to Nikon, $165 repair bill, Camera was returned with no comments, Worked fine until I put the grip back on,,,then same story...mirror up but no shutter release. Removed grip...camera worked fine.

Anyone else had a similar experience or other problems with the ZEIKOS grip?

Subject
ID
Reply message RE: ZEIKOS Power Grip
1
Reply message RE: ZEIKOS Power Grip
2
Reply message RE: ZEIKOS Power Grip
3
     Reply message RE: ZEIKOS Power Grip
4
          Reply message RE: ZEIKOS Power Grip
5
Reply message RE: ZEIKOS Power Grip
6
Reply message RE: ZEIKOS Power Grip
7
     Reply message RE: ZEIKOS Power Grip
8
          Reply message RE: ZEIKOS Power Grip
9
               Reply message RE: ZEIKOS Power Grip
12
Reply message RE: ZEIKOS Power Grip
10
Reply message RE: ZEIKOS Power Grip
11

G