Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Nikon F4 film loading problem

Stealthbong

BH
1 posts

Click to send email to this author Click to send private message to this author
Stealthbong Registered since 26th Jul 2012
Thu 09-Aug-12 06:02 PM

Hi,

I've just bought an immaculate F4s from e-bay, after many years of lusting after one. From the box, through the manual to the camera itself it really is mint. The problem is that am struggling to load film.

I loaded a slide film into it without a problem, but the second film simply won't load.

I've been through the usual checklist:

- checked batteries
- tried drawing film a couple of mil beyond the red mark
- made sure film is spooled both at top and bottom
- tried a different roll of film
- checked both R1 and R2 lever positions

I have never had anything like this kind of problem with my F801. I've been reading some of the other posts on the forum but have only learned that it might cost me nearly $400 to fix if the winding spool has had it. Since I paid $450 for the camera, I'd rather avoid that.

Any ideas??

Many thanks

Jonnie

G