Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Problems with F3 and FA; tips for maintainace?

Klas2000


1 posts

Click to send email to this author Click to send private message to this author
Klas2000 Basic Member
Wed 08-Nov-00 08:53 AM

I have recently aquiered an F3 and FA body with lenses from my aunt. The equipment has spent the last 9 years in my aunt's closet, and I've doug it out and want to use it. But there are minor problems with them

The F3 has problems with using the light meter. When the shutter is pressed halfway down the light meter should be turned on, right? But it seems that parts of the dials and the contact between power supply and light meter is poor or not functioning. The light meter disappears after 16 seconds, and then I can't get it back on - it "timed out" and I have to wait at least 5 min before it works again. Also the body bayonette is not "clicking" when mounting the lenses. Perhaps the lock is full of dust and dirt?

The FA came with a flash, but I can't turn the dial to th M250 setting on the exposure wheel; it seems that the button is stuck.

Any suggestions for simple maintainance, or do I have to delivere it to a specialist?

Great web site, by the way!

Best regards
Peter

G