Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

repost: Can't remove film from f501

mford

UK
2 posts

Click to send email to this author Click to send private message to this author
mford Registered since 05th Nov 2009
Fri 06-Nov-09 03:18 PM

Hi,
I found my fathers old nikon f501 which he left me, and I wanted to try it out. However there seems to be a kodak film still in there. I tried to follow the instructions in the manual (turn to L - slide leaver/push button - rewind) however it doesn't seem to be rewinding and the door won't open. Just wondering if anyone has come across this before and how they fixed it?

update: And I have replaced the batteries, (tried to take a few shots and it seems to work, although nothing happens when I slide the rewind leaver & press the button)

G