Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
Walkerlee

CA
4 posts

Click to send email to this author Click to send private message to this author
Walkerlee Registered since 18th Dec 2006
Sat 15-Nov-08 05:27 AM

I just unloaded a cartridge from my F80, went to load a new one, and the batteries died (which wasn't a surprise). Put new batteries and the new film in, turned in on, and get a flashing "err" and "E". The book tells me that the film isn't loaded properly. I've tried it a few times, different cartridges, and still get the same message. Never had this problem (or any other) with this camera, in the 8 or so years I've owned it. I'm wondering if there some simple thing I'm overlooking, something needs cleaning, or it has to go in for servicing.

G