Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Did I uncover a problem with my D600?

WildIsle

CA
647 posts

Click to send email to this author Click to send private message to this author

"RE: Did I uncover a problem with my D600?"

WildIsle Silver Member Nikonian since 06th Jan 2010
Mon 04-Feb-13 04:06 PM

I'll bet that Eric's got it. There's a reason Nikon (et al) provide a viewfinder cover. A winter scene with low sun directly behind the camera and long exposure to give plenty of time for leakage.. sounds like a perfect recipe for VF light leakage.

You should have a little cover for the viewfinder that comes with every Nikon (without a built in cover like the D800) sounds like it should see some use.

Philip

A general, generic topic Did I uncover a problem with my D600? [View all] , JohnE Nikon , Sun 03-Feb-13 07:17 PM
Subject
ID
Reply message RE: Did I uncover a problem with my D600?
1
Reply message RE: Did I uncover a problem with my D600?
2
     Reply message RE: Did I uncover a problem with my D600?
3
     Reply message RE: Did I uncover a problem with my D600?
5
     Reply message RE: Did I uncover a problem with my D600?
4
          Reply message RE: Did I uncover a problem with my D600?
6
               Reply message RE: Did I uncover a problem with my D600?
7
                    Reply message RE: Did I uncover a problem with my D600?
8
                         Reply message RE: Did I uncover a problem with my D600?
9
                              Reply message RE: Did I uncover a problem with my D600?
10
                                   Reply message RE: Did I uncover a problem with my D600?
11
                                        Reply message RE: Did I uncover a problem with my D600?
12
                                             Reply message RE: Did I uncover a problem with my D600?
13