Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D600 electrical problem or software glitch?

Beth E

US
3 posts

Click to send email to this author Click to send private message to this author

"RE: D600 electrical problem or software glitch?"

Beth E Registered since 05th Jan 2013
Sun 20-Jan-13 04:34 AM | edited Sun 20-Jan-13 10:40 PM by Beth E

In my case, I don't think it is the memory cards. I have tried different ones. I shot a basketball game this morning and it happened again. Only once.

I have this afternoon confirmed that I have extensive dust/oil issues also. With the two issues combined I don't feel comfortable keeping the camera...even if I did get a good "deal" on it right after Christmas during the free kit lens/pricing promotion. I think I am going to return it to B&H for the D800. Thank you for your input.

A general, generic topic D600 electrical problem or software glitch? [View all] , Beth E , Thu 17-Jan-13 01:30 PM
Subject
ID
Reply message RE: D600 electrical problem or software glitch?
1
Reply message RE: D600 electrical problem or software glitch?
2
Reply message RE: D600 electrical problem or software glitch?
3
Reply message RE: D600 electrical problem or software glitch?
4
     Reply message RE: D600 electrical problem or software glitch?
5
Reply message RE: D600 electrical problem or software glitch?
6
Reply message RE: D600 electrical problem or software glitch?
9
Reply message RE: D600 electrical problem or software glitch?
7
Reply message RE: D600 electrical problem or software glitch?
8
     Reply message RE: D600 electrical problem or software glitch?
10