Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
manchooksa

Mentor, US
6 posts

Click to send email to this author Click to send private message to this author

"Oil is the problem, not dust!"

manchooksa Registered since 21st Dec 2012
Fri 28-Dec-12 02:45 PM

I have owned the D80, D200 and two Fujifilm S2 digital cameras and have not had oil issues like the D600. In fact, I only had to deal with dust on the other models. This is oil. No amount of blowing with a Gitzo makes any of it disappear. Nikon is getting a call from me. I wet-cleaned my sensor ten times last night to get the oil off in the same portion of the screen, the left side of the frame from top to bottom. It is stubborn and should not be there. I wonder if the vibrating self-cleaning mode loosens up the oil more? If this was dust it would be randomly placed on the AA filter. It's not. It is the same area. I think Nikon needs to step up and fix it. I am happy with the product somewhat but this shows Nikon is over their head in handling problems. This shouldn't happen with a giant that has such a loyal, if not gullible, following. Count me as one of them.

This is a hot, active topic! Dust or oil ? [View all] , TheGreatMike Silver Member , Sat 27-Oct-12 06:00 PM
Subject
ID
Reply message RE: Dust or oil ?
1
Reply message RE: Dust or oil ?
2
     Reply message RE: Dust or oil ?
3
          Reply message RE: Dust or oil ?
4
               Reply message RE: Dust or oil ?
5
                    Reply message RE: Dust or oil ?
6
Reply message Hard to tell....
7
Reply message RE: Dust or oil ?
8
Reply message RE: Dust or oil ?
9
     Reply message RE: Dust or oil ?
10
          Reply message RE: Dust or oil ?
11
               Reply message RE: Dust or oil ? Possible damaged foam?
12
               Reply message RE: Dust or oil ? Possible damaged foam?
14
               Reply message RE: Dust or oil ?yet
13
                    Reply message RE: Dust or oil ?yet
15
                         Reply message RE: Dust or oil ?yet
16
                              Reply message RE: Dust or oil ?yet
17
                              Reply message RE: Dust or oil ?yet
20
                                   Reply message RE: Dust or oil ?yet
21
                                   Reply message RE: Dust or oil ?yet
26
                              Reply message RE: Dust or oil ?yet
19
                                   Reply message RE: Dust or oil ?yet
22
                                   Reply message RE: Dust or oil ?yet
23
                                   Reply message RE: Dust or oil ?yet
24
                                        Reply message RE: Dust or oil ?yet
25
                                             Reply message RE: Dust or oil ?yet
27
                                                  Reply message RE: Dust or oil ?yet
28
                                                  Reply message RE: Dust or oil ?yet
29
Reply message RE: Dust or oil ?
30
Reply message RE: Dust or oil ?
31
Reply message RE: Dust or oil ?
32
Reply message Oil is the problem, not dust!
33
     Reply message RE: Oil is the problem, not dust!
35
          Reply message update on my D600
36
               Reply message RE: update on my D600
37
Reply message OIL
34
Reply message RE: OIL
38
     Reply message RE: OIL
39
     Reply message RE: OIL
40
          Reply message RE: OIL
41