Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Cannot clean "dot" from sensor...

ECC233

Hochwald, CH
315 posts

Click to send email to this author Click to send private message to this author

"RE: Cannot clean "dot" from sensor..."

ECC233 Registered since 11th Jan 2007
Sun 17-Feb-13 12:04 PM

...that'll be $1500 for a new sensor..."


In your dreams!

Ed


A topic tagged as having a question Cannot clean "dot" from sensor... [View all] , kamputty , Thu 14-Feb-13 01:40 AM
Subject
ID
Reply message RE: Cannot clean "dot" from sensor...
1
Reply message RE: Cannot clean "dot" from sensor...
2
     Reply message RE: Cannot clean "dot" from sensor...
3
          Reply message RE: Cannot clean "dot" from sensor...
4
               Reply message RE: Cannot clean "dot" from sensor...
5
                    Reply message RE: Cannot clean "dot" from sensor...
6
                    Reply message RE: Cannot clean "dot" from sensor...
7
                    Reply message RE: Cannot clean "dot" from sensor...
8
                    Reply message RE: Cannot clean "dot" from sensor...
9
                         Reply message RE: Cannot clean "dot" from sensor...
10
                         Reply message RE: Cannot clean "dot" from sensor...
13
                              Reply message RE: Cannot clean "dot" from sensor...
14
                         Reply message RE: Cannot clean "dot" from sensor...
11
                              Reply message RE: Cannot clean "dot" from sensor...
12