Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Cannot clean "dot" from sensor...

kamputty

Santa Cruz, US
197 posts

Click to send email to this author Click to send private message to this author

"RE: Cannot clean "dot" from sensor..."

kamputty Registered since 04th Jan 2007
Sat 16-Feb-13 10:03 PM

I really need the stamp...how about the pen? Is there a particular brand I should go for?

I still have some crud on the edges...I think the stamp would help there. I have a brush that I manually excite the bristles with a blower for static-ness... Is the auto brush better?

Any advice on loupes? Mine I am sure is a lower end one...

I was soooooooo happy when the dot dislodged...I was getting ready to send to nikon with fears of "...you sensor has a chip on the glass...that'll be $1500 for a new sensor..."

Woot woot!

Kam

Visit my Nikonians gallery.

A topic tagged as having a question Cannot clean "dot" from sensor... [View all] , kamputty , Thu 14-Feb-13 01:40 AM
Subject
ID
Reply message RE: Cannot clean "dot" from sensor...
1
Reply message RE: Cannot clean "dot" from sensor...
2
     Reply message RE: Cannot clean "dot" from sensor...
3
          Reply message RE: Cannot clean "dot" from sensor...
4
               Reply message RE: Cannot clean "dot" from sensor...
5
                    Reply message RE: Cannot clean "dot" from sensor...
6
                    Reply message RE: Cannot clean "dot" from sensor...
7
                    Reply message RE: Cannot clean "dot" from sensor...
8
                    Reply message RE: Cannot clean "dot" from sensor...
9
                         Reply message RE: Cannot clean "dot" from sensor...
10
                         Reply message RE: Cannot clean "dot" from sensor...
13
                              Reply message RE: Cannot clean "dot" from sensor...
14
                         Reply message RE: Cannot clean "dot" from sensor...
11
                              Reply message RE: Cannot clean "dot" from sensor...
12