Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Strobe is firing but camera is not registering

kentak

US
950 posts

Click to send email to this author Click to send private message to this author

"RE: Strobe is firing but camera is not registering"

kentak Silver Member Nikonian since 03rd Jul 2010
Fri 08-Feb-13 12:45 AM

>>The ad quotes 1-3s recharge time.
>
>The Ad quotes a 300w light. Whatever THAT means. Anyone
>who'd add up the wattage of a modeling light, and the strobe
>light and label that as 300w is either:
>
>A. Clueless
>B. Intentionally Misleading
>C. Praying on buyers who don't know any better
>D. Some combination of the above.
>
>

You're right. Incredibly, that's how the brand's website describes the specs. Not to disparage the OP's choice of equipment, but the price would indicate it's a low-end product. One has to wonder how reliable the circuitry is. It's possible the camera and wireless trigger are doing everything right, but the strobe is firing out of sync sporadically. Just speculating.

Kent

A general, generic topic Strobe is firing but camera is not registering [View all] , kellyringphotos , Sat 02-Feb-13 01:35 AM
Subject
ID
Reply message RE: Strobe is firing but camera is not registering
1
Reply message RE: Strobe is firing but camera is not registering
2
     Reply message RE: Strobe is firing but camera is not registering
3
          Reply message RE: Strobe is firing but camera is not registering
4
          Reply message RE: Strobe is firing but camera is not registering
5
               Reply message RE: Strobe is firing but camera is not registering
6
Reply message RE: Strobe is firing but camera is not registering
7
Reply message RE: Strobe is firing but camera is not registering
8
Reply message RE: Strobe is firing but camera is not registering
9
     Reply message RE: Strobe is firing but camera is not registering
10
     Reply message RE: Strobe is firing but camera is not registering
11
     Reply message RE: Strobe is firing but camera is not registering
12
     Reply message RE: Strobe is firing but camera is not registering
13
          Reply message RE: Strobe is firing but camera is not registering
14
               Reply message RE: Strobe is firing but camera is not registering
15
                    Reply message RE: Strobe is firing but camera is not registering
20
     Reply message RE: Strobe is firing but camera is not registering
16
          Reply message RE: Strobe is firing but camera is not registering
17
               Reply message RE: Strobe is firing but camera is not registering
18
                    Reply message RE: Strobe is firing but camera is not registering
19