Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D7000 sensor artifact/problem - help needed

SheriB

Southern York Co, US
1973 posts

Click to send email to this author Click to send private message to this author

"RE: D7000 sensor artifact/problem - help needed"

SheriB Gold Member Awarded for sharing her exceptional images and details of rural farm life. Nikonian since 11th Sep 2010
Sun 09-Dec-12 05:11 PM

I have never seen anyone say that it can be detrimential.I have my 300s and 700 set to clean at start up/shut down and it only lasts a second or two, so no real battery drain.I also am sure it gets turned off and on in many different positions.
If you have not dislodged the spot with a blower and self clean, it is probably already 'welded' there You can do a dust off reference photo though if you still want to avoid wet cleaning.Check you manual for info

Sheri Becker

Visit my Nikonians gallery.

A general, generic topic D7000 sensor artifact/problem - help needed [View all] , batury , Mon 04-Apr-11 11:59 PM
Subject
ID
Reply message RE: D7000 sensor artifact/problem - help needed
1
Reply message RE: D7000 sensor artifact/problem - help needed
2
Reply message RE: D7000 sensor artifact/problem - help needed
3
Reply message RE: D7000 sensor artifact/problem - help needed
4
Reply message RE: D7000 sensor artifact/problem - help needed
5
     Reply message RE: D7000 sensor artifact/problem - help needed
6
          Reply message RE: D7000 sensor artifact/problem - help needed
7
          Reply message RE: D7000 sensor artifact/problem - help needed
8
               Reply message RE: D7000 sensor artifact/problem - help needed
9
                    Reply message RE: D7000 sensor artifact/problem - help needed
10
                    Reply message RE: D7000 sensor artifact/problem - help needed
11
                         Reply message RE: D7000 sensor artifact/problem - help needed
12
                              Reply message RE: D7000 sensor artifact/problem - help needed
13
Reply message RE: D7000 sensor artifact/problem - help needed
14
Reply message RE: D7000 sensor artifact/problem - help needed
15
     Reply message RE: D7000 sensor artifact/problem - help needed
16
          Reply message RE: D7000 sensor artifact/problem - help needed
17
Reply message RE: D7000 sensor artifact/problem - help needed
18
Reply message RE: D7000 sensor artifact/problem - help needed
19