Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Problem with Built in Flash

ReadnFool

US
22 posts

Click to send email to this author Click to send private message to this author

"RE: Problem with Built in Flash"

ReadnFool Registered since 16th Jan 2011
Tue 25-Jan-11 02:16 AM

Ok, got my response from online question I sent in to Nikon.

Basically they said I did everything they would have told me to do and I need to send it in for repair. Gave me the link to print the shipping label, etc.

Kind of crappy to have to do this after owning the camera less than a month, but crud happens. At least it is still under warranty.

Be interesting to see if mine was a fluke or if more people start having a similar problem.

Steve
ReadnFool

Visit my Nikonians gallery.

A general, generic topic Problem with Built in Flash [View all] , ReadnFool , Sun 23-Jan-11 02:35 AM
Subject
ID
Reply message RE: Problem with Built in Flash
1
Reply message RE: Problem with Built in Flash
2
     Reply message RE: Problem with Built in Flash
3
          Reply message RE: Problem with Built in Flash
4
Reply message RE: Problem with Built in Flash
5
Reply message RE: Problem with Built in Flash
6
Reply message RE: Problem with Built in Flash
7