Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
swannking

US
11 posts

Click to send email to this author Click to send private message to this author

"RE: Battery(s)?"

swannking Registered since 13th Nov 2012
Wed 23-Jan-13 02:06 AM

My camera did some odd things when I used the non-Nikon grip and even with the Nikon grip when it was paired with a 3rd party battery.

>No luck for me.
>
>I thought it might be because I have the camera set for an
>EL-EN15 in the grip. I scrounged up my AA insert, loaded it
>up, and changed the d13 setting. Took out the camera
>battery..... zip.
>
>Then again, my grip isn't OEM.

A general, generic topic Battery(s)? [View all] , chesterdawg , Tue 22-Jan-13 05:46 PM
Subject
ID
Reply message RE: Battery(s)?
1
Reply message RE: Battery(s)?
2
     Reply message RE: Battery(s)?
3
          Reply message RE: Battery(s)?
4
               Reply message RE: Battery(s)?
5
                    Reply message RE: Battery(s)?
6
                         Reply message RE: Battery(s)?
7
                         Reply message RE: Battery(s)?
8
                              Reply message RE: Battery(s)?
10
                         Reply message RE: Battery(s)?
9
Reply message RE: Battery(s)?
11