Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Grip battery "Intermittent"

richardd300

Dyserth, UK
4509 posts

Click to send email to this author Click to send private message to this author

"RE: Grip battery "Intermittent""

richardd300 Silver Member Nikonian since 19th Apr 2009
Sun 20-May-12 09:30 PM | edited Sun 20-May-12 09:31 PM by richardd300

I've had this problem with my D7000 grip, never with the D700 grip! Exactly the same, 3 bars or less, then re-mount and screw back tightly gives 5 bars. It's about oxidation I think and I now use a cotton wool bud with some mentholated spirits and clean the contacts about once every few months and it's not happened again.

I also believe the MB-D10 grip For the my D700 is of a much higher build quality.

Richard

Visit my Nikonians gallery

Visit my website www.pixels4u.co.uk
The important thing is not to stop questioning. Curiosity has its own reason for existing. Einstein

A general, generic topic Grip battery "Intermittent" [View all] , slothead Gold Member Donor Ribbon awarded for his generous support to the Fundraising Campaign 2014 , Sat 19-May-12 09:50 AM
Subject
ID
Reply message RE: Grip battery "Intermittent"
1
Reply message RE: Grip battery "Intermittent"
2
     Reply message RE: Grip battery "Intermittent"
3