Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Adhesive bond failure on D700 exterior rubber panels

Bob32

Chico, US
5870 posts

Click to send email to this author Click to send private message to this author

"RE: Adhesive bond failure on D700 exterior rubber panels"

Bob32 Silver Member Nikonian since 29th Jul 2007
Wed 14-Mar-12 06:28 PM

GH,

I also thought about fixing it myself and even bought a tube of Pliobond to do the job. However, I read some caveats about that sort of remedy and finally decided to let it be done the best way.

I'm curious when Nikon decided to apply these rubber panels to the exterior of their camera bodies. This dubious practice must have commenced sometime between the time I bought my F2A in 1979 and my D200 purchase in 2007.

Bob

A general, generic topic Adhesive bond failure on D700 exterior rubber panels [View all] , Bob32 Silver Member , Wed 14-Mar-12 03:10 PM
Subject
ID
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
1
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
2
     Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
4
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
3
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
5
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
6
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
7
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
8
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
9
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
10
Reply message RE: Adhesive bond failure on D700 exterior rubber panel...
11