Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Epson 4900 Problem

philipl

Oxford, US
1784 posts

Click to send email to this author Click to send private message to this author

"RE: Epson 4900 Problem"

philipl Gold Member Nikonian since 31st May 2007
Tue 05-Feb-13 07:37 PM

Thanks very much. I did try the pwerful cleaning cycle a half dozen times; no help. indeed before one cleaning cycle on LLK/Y the cyan jet worked fine. When I did the next nozel check print after the cyan jet was completely out.

I have turned the printer on and off many times over 2 weeks and done many cleanings all to no avail. I have had a lot of trouble with LLK since the beginning.

I will try and clean the print head myself. If it doesn't work I will likely buy a new one (with 3 year extended warranty).

Thanks again

Philip

Do not settle for mediocrity. Rather strive for excellence for even in that attempt lies a measure of success.

https://images.nikonians.org/galleries/showgallery.php/cat/500/ppuser/139567[br />"]My Gallery

A general, generic topic Epson 4900 Problem [View all] , philipl Gold Member , Mon 04-Feb-13 02:04 PM
Subject
ID
Reply message RE: Epson 4900 Problem
1
Reply message RE: Epson 4900 Problem
2