Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

question about extension tubes

Pete Wilson

Lake Orion, US
888 posts

Click to send email to this author Click to send private message to this author

"RE: question about extension tubes"

Pete Wilson Gold Member Winner in the Annual Nikonians Best Images Contest 2015 Nikonian since 27th Jun 2004
Sun 23-Dec-12 01:46 AM

If its HSM then it doesn't even use the screw drive. HSM lenses have their own focus motor built in them. The pictures of the sigma 105 macros with HSM on them all had the lettering HSM on the lens.

Like Len said, your going to have to do trial and error. Try each extension tube by itself on the camera with that lens and see if it works. This will tell you if it is just one tube and which one it is. BTW, I have had my kenko extension tubes for about 6 years and I have yet to ever need to use more than one at a time.

Pete Wilson
Nikonian from Lake Orion, Michigan
My Nikonians gallery

Nikonians membership - My most important photographic investment, after the
camera

A general, generic topic question about extension tubes [View all] , pasknucklehead Silver Member , Sat 22-Dec-12 05:13 PM
Subject
ID
Reply message RE: question about extension tubes
1
Reply message RE: question about extension tubes
2
     Reply message RE: question about extension tubes
3
     Reply message RE: question about extension tubes
4
          Reply message RE: question about extension tubes
5
Reply message RE: question about extension tubes
6