Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300/MB-D10 grip controls not working

rbaskin

Ridgefield, US
381 posts

Click to send email to this author Click to send private message to this author

"RE: D300/MB-D10 grip controls not working"

rbaskin Silver Member Nikonian since 05th Feb 2007
Fri 08-Nov-13 09:02 PM

I recall having a similar problem twice.

I turned off the grip and the camera, disconnected the grip, and removed both batteries. After reversing the procedure, all seemed to work well.

Haven't had it happen again in the last 2 years.

As a last resort you could perform a reset on the camera in the hopes of resetting the connection between the grip and camera.

Hope this helps.

Ralph in CT

A general, generic topic D300/MB-D10 grip controls not working [View all] , NRVVA Gold Member , Thu 07-Nov-13 10:39 PM
Subject
ID
Reply message RE: D300/MB-D10 grip controls not working
1
Reply message RE: D300/MB-D10 grip controls not working
2
     Reply message RE: D300/MB-D10 grip controls not working
3
     Reply message RE: D300/MB-D10 grip controls not working
4
Reply message RE: D300/MB-D10 grip controls not working
5
Reply message RE: D300/MB-D10 grip controls not working
6
     Reply message RE: D300/MB-D10 grip controls not working
7
          Reply message RE: D300/MB-D10 grip controls not working
8