Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Hot Pixels on my D300

garysphinx5779

UK
14 posts

Click to send email to this author Click to send private message to this author

"Hot Pixels on my D300"

garysphinx5779 Registered since 16th Jun 2013
Sun 16-Jun-13 10:37 AM

I noticed recently that I have a cluster of about 9 pixels showing red. I contacted Nikon technical support who looked at some photos and confirmed they are 'hot' pixels and say I have to send the camera in for repair. My D300 is almost 5 years old so well out of warranty, and Nikon say they cannot give me even a ballpark figure that the repair will cost, although they will advise me of the cost before they do the repair.

Adobe Camera Raw automatically gets rid of the red dot the hot pixels cause, so I do not know if to send it in for repair or just live with it. Has anyone else got this problem? Any advice anyone can give me would be much appreciated.

A general, generic topic Hot Pixels on my D300 [View all] , garysphinx5779 , Sun 16-Jun-13 08:37 AM
Subject
ID
Reply message RE: Hot Pixels on my D300
1
Reply message RE: Hot Pixels on my D300
2
Reply message RE: Hot Pixels on my D300
3
Reply message RE: Hot Pixels on my D300
4
     Reply message RE: Hot Pixels on my D300
5
     Reply message RE: Hot Pixels on my D300
6