Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300 mysteriously died

Stagecoach

Suva, FJ
132 posts

Click to send email to this author Click to send private message to this author

"RE: D300 mysteriously died"

Stagecoach Silver Member Nikonian since 03rd Apr 2009
Mon 29-Apr-13 01:11 AM

Hi Roger

I'm a D300 owner and luckily have never experienced any problems with the camera except operator error.

With respect to the 'ffffssst' sound it made when you pushed the battery harder in sounds like some sort of short that has now killed it totally.

You mention that you use the Kenko Teleconverters and wonder if the problems you are experiencing are specific to when these are fitted ?

I mention this because I have read various articles where concern is raised at the intermittent failure of certain functions due to the loss of continuity of electrical contact caused by slight play in the mounting. Although these concerns were with regard to the Kenko Tubes and the affect from heavier lenses it is something to be aware of.

Visit my Nikonians gallery.

A general, generic topic D300 mysteriously died [View all] , roghayden , Sun 28-Apr-13 04:24 PM
Subject
ID
Reply message RE: D300 mysteriously died
1
Reply message RE: D300 mysteriously died
2
Reply message RE: D300 mysteriously died
3
Reply message RE: D300 mysteriously died
4
     Reply message RE: D300 mysteriously died
5