Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300s vs D300 auto-ISO flash issue

PIKBill

Miami, US
12 posts

Click to send email to this author Click to send private message to this author

"RE: D300s vs D300 auto-ISO flash issue"

PIKBill Gold Member Nikonian since 12th Oct 2012
Tue 20-Nov-12 09:49 PM

Hi Chris,

>Yes, the implementation of Auto ISO & flash changed on the
>D300s and subsequent cameras. The camera seems to use Auto ISO
>to try & get a 'correct' ambient exposure before adding
>flash, rather than keeping the ISO low and adding more flash
>to get a good exposure. I don't think many people like the
>newer implementation, even though (for TTL-BL) it might be
>argued to be more 'correct'.

This was the answer I was looking for. For myself and under my own conditions, the pre-D300s implementation has proved to work just fine and I prefer it, but I will adjust my technique accordingly now that I will be using the D300s and as I learn more.

Thank you to everyone one for your time and insightful responses.

Best,

Bill


Visit my Nikonians gallery.

A topic tagged as in need of help D300s vs D300 auto-ISO flash issue [View all] , PIKBill Gold Member , Sun 18-Nov-12 08:24 PM
Subject
ID
Reply message RE: D300s vs D300 auto-ISO flash issue
1
Reply message RE: D300s vs D300 auto-ISO flash issue
2
     Reply message RE: D300s vs D300 auto-ISO flash issue
3
Reply message RE: D300s vs D300 auto-ISO flash issue
4
Reply message RE: D300s vs D300 auto-ISO flash issue
5
Reply message RE: D300s vs D300 auto-ISO flash issue
6
Reply message RE: D300s vs D300 auto-ISO flash issue
7