Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D300s vs D300 auto-ISO flash issue

greenwing

Yorkshire, UK
1304 posts

Click to send email to this author Click to send private message to this author

"RE: D300s vs D300 auto-ISO flash issue"

greenwing Registered since 18th May 2006
Mon 19-Nov-12 12:13 PM

>What I would like to know is if I may have a problem with the
>D300s or if I have something set incorrectly? is this just a
>known difference between the D300 and D300s?

Hi Bill,

Yes, the implementation of Auto ISO & flash changed on the D300s and subsequent cameras. The camera seems to use Auto ISO to try & get a 'correct' ambient exposure before adding flash, rather than keeping the ISO low and adding more flash to get a good exposure. I don't think many people like the newer implementation, even though (for TTL-BL) it might be argued to be more 'correct'.

Chris

A topic tagged as in need of help D300s vs D300 auto-ISO flash issue [View all] , PIKBill Gold Member , Sun 18-Nov-12 08:24 PM
Subject
ID
Reply message RE: D300s vs D300 auto-ISO flash issue
1
Reply message RE: D300s vs D300 auto-ISO flash issue
2
     Reply message RE: D300s vs D300 auto-ISO flash issue
3
Reply message RE: D300s vs D300 auto-ISO flash issue
4
Reply message RE: D300s vs D300 auto-ISO flash issue
5
Reply message RE: D300s vs D300 auto-ISO flash issue
6
Reply message RE: D300s vs D300 auto-ISO flash issue
7