Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Strange Smudge/Fibre/Hair on D300s sensor?

dm1dave

Lowden, US
13619 posts

Click to send email to this author Click to send private message to this author

"RE: Strange Smudge/Fibre/Hair on D300s sensor?"

dm1dave Administrator Awarded for high level knowledge and skills in various areas, most notably in Wildlife and Landscape Writer Ribbon awarded for his excellent article contributions to the Nikonians community Donor Ribbon awarded for his very generous support to the Fundraising Campaign 2015 Nikonian since 12th Sep 2006
Sun 02-Sep-12 03:00 AM

I have the sensor cleaning feature set to both startup and shut down. I can help and it will never hurt to have it on.

Dave Summers
Nikonians Photo Contest Director
My Nikonians Gallery | Current Nikonians Contests

Click on image to view larger version

A general, generic topic Strange Smudge/Fibre/Hair on D300s sensor? [View all] , digitalandfilm , Sun 02-Sep-12 12:14 AM
Subject
ID
Reply message RE: Strange Smudge/Fibre/Hair on D300s sensor?
1
Reply message RE: Strange Smudge/Fibre/Hair on D300s sensor?
2
Reply message RE: Strange Smudge/Fibre/Hair on D300s sensor?
3
     Reply message RE: Strange Smudge/Fibre/Hair on D300s sensor?
4