Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Oil spotlets on sensor filters

grizzly200

Solano County, California, US
707 posts

Click to send email to this author Click to send private message to this author

"RE: Oil spotlets on sensor filters"

grizzly200 Registered since 18th Dec 2011
Mon 03-Sep-12 03:50 AM | edited Mon 03-Sep-12 03:55 AM by grizzly200

Bert,
I actually brought much of my oil spot problem on myself when I stupidly used a blower brush with bristles inside the mirror box area before boning up on how to deal with these sensors. Of course, after doing that, I had moist fragments from inside the box, and oil spots which I had stirred up myself. That's when I went to CopperHill and educated myself.

Next cleaning will be much calmer and much more efficient, I'm sure.

Regarding difficulty finding posts on these matters, you make a good point. I haven't checked the NikoScope feature, but if one searched on "sensor cleaning," these threads might come up. Actually, the Nikonians Cafe would probably be the place to post this type of info.

UPDATE: I tried NikoScope search feature, and it did bring up many posts on the subject. I'm glad you got your sensor well cleaned!

James

A general, generic topic Oil spotlets on sensor filters [View all] , Bert Shelton , Sat 01-Sep-12 02:00 PM
Subject
ID
Reply message RE: Oil spotlets on sensor filters
1
Reply message RE: Oil spotlets on sensor filters
2
     Reply message RE: Oil spotlets on sensor filters
3
     Reply message RE: Oil spotlets on sensor filters
4
          Reply message RE: Oil spotlets on sensor filters
5
               Reply message RE: Oil spotlets on sensor filters
6