Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Oil spotlets on sensor filters

marsmail

UK
170 posts

Click to send email to this author Click to send private message to this author

"RE: Oil spotlets on sensor filters"

marsmail Registered since 27th Aug 2010
Sun 02-Sep-12 04:34 PM

I too have had this problem in the past.
Being relatively new to digital it was a scary thing to try cleaning a sensor, but after the first go, I realised that it was really not such a big thing, just needing to be calm and work gently.
I use "Visible Dust" swabs and cleaning fluid and after fixing the initial problem (not long after getting my D300s), have not had a recurrance of the oil spots.
As you say, it would appear that this might be a fairly common problem.

regards

marsmail

A general, generic topic Oil spotlets on sensor filters [View all] , Bert Shelton , Sat 01-Sep-12 02:00 PM
Subject
ID
Reply message RE: Oil spotlets on sensor filters
1
Reply message RE: Oil spotlets on sensor filters
2
     Reply message RE: Oil spotlets on sensor filters
3
     Reply message RE: Oil spotlets on sensor filters
4
          Reply message RE: Oil spotlets on sensor filters
5
               Reply message RE: Oil spotlets on sensor filters
6