Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Cable release problems

GaryMorrison

Bloomington, US
32 posts

Click to send email to this author Click to send private message to this author
GaryMorrison Silver Member Nikonian since 20th Sep 2008
Tue 23-Jul-13 02:44 PM

I seem to be having problems with my cable release in both manual and auto focus with mirror up.

I have used both the MC-DC2 with the Nikon GPS and the Nikon MC-30. They will almost always make the mirror go up, but the second press does nothing and I have to press the shutter button on the camera to finish the shot.

I bought a new MC-DC2 thinking maybe the wires were pinched or broken, but it did not solve the problem. The other day I switched to the MC-30 and had the same problem.

It does not happen all the time, but when it does happen, it is a problem for maybe 5-10 shots.

I am almost positive the shutter release on the body works fine.

Any thoughts?

Gary

Visit my Nikonians gallery.

Visit my Nikonians gallery.

Visit my Nikonians gallery.

avm247

Rancho Cordova, US
18758 posts

Click to send email to this author Click to send private message to this author

#1. "RE: Cable release problems" | In response to Reply # 0

avm247 Moderator Awarded for high skills in documentary architecture and aviation photography Donor Ribbon. Awarded for his support to the Fundraising Campaign 2014 Charter Member
Tue 06-Aug-13 05:59 PM

I have only used the MC-30 and not in mirror lock up mode but have not had any problems.

Have you been able to sort it out yet, Gary?


Anthony

The Moderator Page and My Gallery
The important things in life are simple; the simple things are hard.

MEMcD

US
31609 posts

Click to send email to this author Click to send private message to this author

#2. "RE: Cable release problems" | In response to Reply # 0

MEMcD Moderator In depth knowledge in various areas Nikonian since 24th Dec 2007
Tue 03-Sep-13 06:51 AM

Hi Gary,

I have never experienced that problem with either my MC-30 or MC-36.
The second press always releases the shutter in Mup mode.

Best Regards,
Marty

GaryMorrison

Bloomington, US
32 posts

Click to send email to this author Click to send private message to this author

#3. "RE: Cable release problems" | In response to Reply # 1

GaryMorrison Silver Member Nikonian since 20th Sep 2008
Tue 03-Sep-13 10:18 AM

It seems to be intermittent which is quite frustrating.

Visit my Nikonians gallery.

Visit my Nikonians gallery.

Visit my Nikonians gallery.

G