Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

D700 with MB-D10

Leighgregory

Swindon, UK
1614 posts

Click to send email to this author Click to send private message to this author
Leighgregory Silver Member Nikonian since 08th Sep 2006
Sun 02-Sep-12 10:55 AM

Hello everyone,

I am after some advice with my MB-D10 and D700 set up.

I brought it second hand so am not sure if its faulty, or if im doing something wrong?

In the shooting menu, menu d10 (MB-D10 battery type) I have selected HR6 AA Ni-MH as the Hama rechargeable batteries I have say NIMH 1,2V HR6 on them.

In the shooting menu, menu d11 (battery order) I have selected Use MB-D10 batteries first.

So my question is when I look in the battery info menu I get the screen below, I never get a percentage against the MB-D10 side and it seems the D700 battery is being not the MB-D10 battery.

I don’t have the holder for another EN-EL3e yet so I cant test that.

The grip functions perfectly with or without the batteries.

Any advice would be very much appreciated.

Thanks

Leigh

A Nikonion in Swindon, UK.

My website

Visit my Nikonians gallery.

Visit my Nikonians gallery.



Click on image to view larger version


Attachment#1 (jpg file)

Leighgregory

Swindon, UK
1614 posts

Click to send email to this author Click to send private message to this author

#1. "RE: D700 with MB-D10" | In response to Reply # 0

Leighgregory Silver Member Nikonian since 08th Sep 2006
Sun 02-Sep-12 09:18 AM

It seems i've found a remedy...

I had to power up the camera without a battery in the D700, this kick started things, the LCD screen now says BP next to the battery indicator and I have 8 frames a second.

Sorry to waste your time!

Thanks

Leigh

A Nikonion in Swindon, UK.

My website

Visit my Nikonians gallery.

Visit my Nikonians gallery.

jgould2

Fort Pierce, US
4582 posts

Click to send email to this author Click to send private message to this authorClick to send message via AOL IM

#2. "RE: D700 with MB-D10" | In response to Reply # 1

jgould2 Gold Member Fellow Ribbon awarded for his excellent and frequent contributions and sharing his in-depth knowledge and experience with the community in the Nikonians spirit. Nikonian since 13th Oct 2007
Mon 03-Sep-12 12:43 PM

Hi Leigh.

You did not waste anyone's time! These forums are here so we can all share our experiences. Personally I was happy to be reminded of the solution to this problem. It hasn't happenened to me with my D700 and battery grip (yet) but I like knowing what to do if it does.

JIM

G