Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

English German French

Sign up Login
Home Forums Articles Galleries Recent Photos Contest Help Search News Workshops Shop Upgrade Membership Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

New Version of NX/NX2 Required?

sfbillm

Santa Fe, US
870 posts

Click to send email to this author Click to send private message to this author
sfbillm Silver Member Nikonian since 15th Jun 2004
Tue 01-Jul-08 01:45 PM

The Nikon press release doesn't seem to say anything about the software to use with the D700.

Do the current versions of NX and/or NX2 support the D700? Or will updates be required?

Thanks.

SantaFeBill

Prowicz

UK
259 posts

Click to send email to this author Click to send private message to this author

#1. "RE: New Version of NX/NX2 Required?" | In response to Reply # 0

Prowicz Registered since 11th May 2008
Tue 01-Jul-08 11:49 AM

What I read, the D700 will only work with NX2

--------------------------------------------------------

Mark (Prowicz)

South Wales, United Kingdom based NIKONIAN

sfbillm

Santa Fe, US
870 posts

Click to send email to this author Click to send private message to this author

#2. "RE: New Version of NX/NX2 Required?" | In response to Reply # 1

sfbillm Silver Member Nikonian since 15th Jun 2004
Tue 01-Jul-08 01:15 PM

>What I read, the D700 will only work with NX2

Thanks for the info. I'd rather expected that would be the case. But will the current NX2 support it, or will an update be required? IIRC, in the past, sometimes when a new DSLR was introduced, the then-current version of NC or NX required an update to support the new camera.

SantaFeBill

J Zee

US
418 posts

Click to send email to this author Click to send private message to this author

#3. "RE: New Version of NX/NX2 Required?" | In response to Reply # 2

J Zee Silver Member Nikonian since 30th Apr 2004
Tue 01-Jul-08 06:33 PM

Every time Nikon has introduced new bodies they've made an update available for View NX and Capture NX. I am sure they will do so this time, too.


J Zee

Now, If I Can Just Do Justice To My Equipment..

yoose

Tucson, US
111 posts

Click to send email to this author Click to send private message to this author

#4. "RE: New Version of NX/NX2 Required?" | In response to Reply # 2

yoose Registered since 23rd Sep 2007
Tue 01-Jul-08 07:00 PM

one would hope that since they have known this camera will come out and NX2 was just released that they would have made NX2 already compatible, but who knows. The files could be the same as the D3s with a D700 for the camera name.

DrJay32

Colorado Springs, US
3380 posts

Click to send email to this author Click to send private message to this author

#5. "RE: New Version of NX/NX2 Required?" | In response to Reply # 0

DrJay32 Gold Member Awarded for his multiple written contributions for the Resources and eZine Nikonian since 12th Mar 2003
Tue 01-Jul-08 07:31 PM

Based on history, you'll need NX 2.0, and NX 1.x won't support it.

Whether NX 2.0 will require an update is something I don't know.

-Jason

Jason P. Odell
Colorado Nikonian
Author, The Photographer's Guide to Capture NX2
The authoritative guide to Capture NX 2.0!

www.luminescentphoto.com

Listen to The Image Doctors

RWCooper

Winnipeg, CA
1019 posts

Click to send email to this author Click to send private message to this author

#6. "RE: New Version of NX/NX2 Required?" | In response to Reply # 0

RWCooper Silver Member Nikonian since 04th Jul 2004
Wed 02-Jul-08 04:07 PM

Hi,

I spoke with someone at the camera shop I deal with here in Canada and he stated that they are still getting Capture NX included with the D300s they sell. Perhaps NX2 will come with the D700 in some countries. I'm waiting to hear back if this is the case in Canada.

Enjoy!

Randy

G