Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Lightroom 5 printing issues to Epson 3800

This topic is locked. This message is locked.

Dresher, US
53 posts

Click to send email to this author Click to send private message to this author
ms8107242 Registered since 10th Dec 2003
Mon 22-Jul-13 09:35 PM

Started out at printing forum here, but think it is most likely a LR issue, as follows:

Have been printing my images to this printer from LR for quite some time, including using LR5, and as recently as last week able to print successfully 8X10s using templates I had built in LR. Yesterday, tried to print 17X25, and the print came out only with 8X10 printed on. Then went back to the 8X10 that I had successfully printed only a few days before, and the 8X10 print had only 4X6 printed on it. Nothing had changed with my LR print templates, so am greatly confused by this printer behavior.

The only thing that prints correctly are 4X6 prints. They print as normal, fully sized 4X6.

Subsequently discovered that I could print 8X10 in portrait mode with no issue, but having no success in landscape mode.

Today, called Epson tech support and was able to print the same landscape image from Preview ... so according to Epson, it is a software issue. At this point, any ideas how to correct this LR issue? Should i just reinstall the software?


Visit my Nikonians gallery.

Visit my Nikonians gallery.

Visit my Nikonians gallery.