Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #7140
View in linear mode

Subject: "D5000 with Sb-900 Speedlite, problem" Previous topic | Next topic
Ferrari7a Registered since 02nd Dec 2012Sun 02-Dec-12 06:47 PM
2 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"D5000 with Sb-900 Speedlite, problem"


DK
          

When i take a phot with the build-in flash on D5000 it's okay everytime.
But when i connect the SB-900 Speedlite flash, then it's only the first photo who is well illuminated, the rest will be very underexposed.

This is really a riddle for me what's wrong?

I have reset both camera and flash, nothing helps. Does somebody have a good suggestion?

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic
Subject Author Message Date ID
Reply message RE: D5000 with Sb-900 Speedlite, problem
Leonard62 Gold Member Awarded for excellent contributions and sharing his in-depth knowledge and experience with the community, especially of Nikkor Lenses
02nd Dec 2012
1
Reply message RE: D5000 with Sb-900 Speedlite, problem
Ferrari7a
02nd Dec 2012
2
     Reply message RE: D5000 with Sb-900 Speedlite, problem
Leonard62 Gold Member Awarded for excellent contributions and sharing his in-depth knowledge and experience with the community, especially of Nikkor Lenses
03rd Dec 2012
3
Reply message RE: D5000 with Sb-900 Speedlight problem
gkaiseril Gold Member
03rd Dec 2012
4
Reply message RE: D5000 with Sb-900 Speedlite, problem
MEMcD Moderator In depth knowledge in various areas
03rd Dec 2012
5

Leonard62 Gold Member Awarded for excellent contributions and sharing his in-depth knowledge and experience with the community, especially of Nikkor Lenses Nikonian since 15th Mar 2009Sun 02-Dec-12 07:01 PM
3296 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "RE: D5000 with Sb-900 Speedlite, problem"
In response to Reply # 0


Hatboro, Pa, US
          

How are the batteries? Are you leaving enough time between shots for the capacitor to fully charge?

Len

Visit my Nikonians gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
Ferrari7a Registered since 02nd Dec 2012Sun 02-Dec-12 07:27 PM
2 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#2. "RE: D5000 with Sb-900 Speedlite, problem"
In response to Reply # 1


DK
          

Batteries are okay, just recharged and the flash respond very fast. But i have discovered that it takes some time again before it will do autofocus and measuring. So i don't know what the problem is.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

        
Leonard62 Gold Member Awarded for excellent contributions and sharing his in-depth knowledge and experience with the community, especially of Nikkor Lenses Nikonian since 15th Mar 2009Mon 03-Dec-12 02:56 PM
3296 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#3. "RE: D5000 with Sb-900 Speedlite, problem"
In response to Reply # 2


Hatboro, Pa, US
          

If you can try another flash you might isolate the problem more. I guess it could be a camera problem but I haven't heard of the problem before.

Len

Visit my Nikonians gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

gkaiseril Gold Member Nikonian since 28th Oct 2005Mon 03-Dec-12 04:03 PM
6739 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#4. "RE: D5000 with Sb-900 Speedlight problem"
In response to Reply # 0


Chicago, US
          

Do you have the "Red Eye Reduction" turned on?

Do you have the SB-900 Speedlight set to the "Master" mode/

George
My Nikonian Galleries

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

MEMcD Moderator In depth knowledge in various areas Nikonian since 24th Dec 2007Mon 03-Dec-12 07:05 PM
26762 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#5. "RE: D5000 with Sb-900 Speedlite, problem"
In response to Reply # 0


US
          

Hi Jan,

Welcome to Nikonians!
Does the SB-900 fit snugly in the cameras hotshoe or is there excessive play?
Is the Speedlight locked into the cameras hotshoe?
Did you try cleaning the electrical contacts on both the Camera and the Speedlight?
Good Luck and Enjoy your Nikons!

Best Regards,
Marty

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #7140 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.