Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Nikon D5100 focus screen and viewfinder


1 posts

Click to send email to this author Click to send private message to this author
NuclearOptimism Registered since 17th Sep 2012
Mon 17-Sep-12 05:09 PM

Hi everyone, I'm reasonably new to DSLR photography, so apologies in advance if I use the wrong terminology.

A while ago I was looking through the viewfinder when I noticed a small mark near the corner of the image. I was terrified that I had got dirt on the sensor and would have to get it cleaned. Luckily, this mark did not appear on the subsequent images, leading me to believe it was just on the focus screen. I therefore decided not to interfere and ignore the mark, as it doesn't affect my photos.

However, another problem has arisen. I was taking some pictures of the horizon, and was very careful to make sure it was perfectly horizontal (obviously). Everything seemed level when I was using the viewfinder, but when I looked at the pictures on my computer (and on the camera screen), they were a little off-balance, by a degree or two. At first I thought my hand had slipped, so I tested it some more, and time and time again everything is "slanted" by a degree or two. I had to rotate all my pictures in photoshop and trim the edges, which was a pain.

Am I right in thinking that my focus screen is misaligned? If so, is it difficult (and expensive) to fix or replace? The mark I can ignore, the lack of balance I cannot.

I know I could just use the screen to take my photos (which doesn't result in slanted pictures), but I find that wastes the battery. I find it much more convenient to use the viewfinder, particularly on holiday when I'm taking a lot of photos all day.

Any diagnosis would be greatly appreciated.

To give you a really quick example, this skirting board looked perfectly level when I was using the focus screen/viewfinder:

I know the first response will be that I'm just holding it wrong, but I've been using a tripod, with the same result.