Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #3120
View in linear mode

Subject: "Automatic sensor cleaning settings" Previous topic | Next topic
Wordchipper Registered since 12th Jan 2011Wed 12-Jan-11 03:09 AM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"Automatic sensor cleaning settings"


US
          

I have a new Nikon D3100 and there are several options for the camera to do sensor cleaning. You can choose "clean at off and on" or just when you turn the camera on or when you turn it off. There is also a manual "clean now" option. My question is: After selecting the "clean after turn off or on.." or any of those automatic options, there is NO indication that the camera has accepted the selection and I feel there is no cleaning activity coming from the camera. The only option that works is "clean now" and then I can feel the camera going through the process. Why don't those other options show up on the menu as selected? What am I doing wrong?

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic
Subject Author Message Date ID
Reply message RE: Automatic sensor cleaning settings
nikon3100
12th Jan 2011
1
Reply message RE: Automatic sensor cleaning settings
Asgard Administrator
12th Jan 2011
2
Reply message RE: Automatic sensor cleaning settings
jpFoto
12th Jan 2011
3
     Reply message RE: Automatic sensor cleaning settings
Wordchipper
13th Jan 2011
4
          Reply message RE: Automatic sensor cleaning settings
nikon3100
13th Jan 2011
5
          Reply message RE: Automatic sensor cleaning settings
Wordchipper
13th Jan 2011
7
               Reply message RE: Automatic sensor cleaning settings
nikon3100
13th Jan 2011
8
                    Reply message RE: Automatic sensor cleaning settings
Wordchipper
13th Jan 2011
9
                         Reply message RE: Automatic sensor cleaning settings
nikon3100
13th Jan 2011
10
                              Reply message RE: Automatic sensor cleaning settings
jpFoto
13th Jan 2011
11
                                   Reply message RE: Automatic sensor cleaning settings
Wordchipper
13th Jan 2011
12
                                        Reply message RE: Automatic sensor cleaning settings
nikon3100
14th Jan 2011
13
                                             Reply message RE: Automatic sensor cleaning settings
Wordchipper
14th Jan 2011
14
                                             Reply message RE: Automatic sensor cleaning settings
nikon3100
17th Jan 2011
15
                                             Reply message RE: Automatic sensor cleaning settings
Wordchipper
17th Jan 2011
16
                                             Reply message RE: Automatic sensor cleaning settings
nikon3100
17th Jan 2011
17
          Reply message RE: Automatic sensor cleaning settings
jpFoto
13th Jan 2011
6

nikon3100 Registered since 14th Dec 2010Wed 12-Jan-11 08:28 AM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "RE: Automatic sensor cleaning settings"
In response to Reply # 0


PT
          

Hi and welcome to the forum.

It's perfectly normal not to get any notification of the automatic cleaning process being performed. I have my D3100 set to clean the sensor when switched on and when turned off. I figured I'd like to get any dust off the sensor as soon as possible before it has a chance to properly bond over time on due to any humidity that may be in the air.

The automatic cleaning and notification was also discussed in this thread http://www.nikonians.org/forums/dcboard.php?az=show_topic&forum=312&topic_id=3063&mesg_id=3063&page=

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Asgard Administrator He is your Chief Guardian Angel at the Helpdesk and knows a lot about a lot Nikonian since 07th Apr 2004Wed 12-Jan-11 07:16 PM
50948 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#2. "RE: Automatic sensor cleaning settings"
In response to Reply # 0


East Frisia, DE
          

Hi Larry,

First I want to Welcome you to Nikonians

As mentioned, you will not noticed it, but it works



Gerold - Nikonian in East Frisia
Eala Freya Fresena

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
jpFoto Registered since 25th Jun 2010Wed 12-Jan-11 10:58 PM
1114 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#3. "RE: Automatic sensor cleaning settings"
In response to Reply # 2


US
          

Hi Gerold,

As you know, I responded to the previous post about not receiving any indication that the sensor is being cleaned at start up or at shut down. I began thinking about the issue, and I know that we all get the same response, or shall I say lack of response, but how do we really know that anything is actually happening? Maybe there really is a firmware problem. What do you think?

jP

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

        
Wordchipper Registered since 12th Jan 2011Thu 13-Jan-11 02:45 AM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#4. "RE: Automatic sensor cleaning settings"
In response to Reply # 3


US
          

>Hi Gerold,
>
>As you know, I responded to the previous post about not
>receiving any indication that the sensor is being cleaned at
>start up or at shut down. I began thinking about the issue,
>and I know that we all get the same response, or shall I say
>lack of response, but how do we really know that anything is
>actually happening? Maybe there really is a firmware problem.
> What do you think?
>
>jP


AM QUITE NEW TO THIS FORUM and not sure how to reply but I must say I really appreciate the direction to this section about sensor cleaning on the 3100 AND for the several responses I have received so far.

JP raises an interesting question - as to whether or not this is a firmware problem. I mean when I do the "clean now" option there is a distinct vibration that some kind of activity is going on. However, that doesn't happen with the "on/off" or the "on" or "off" selections. Nothing seems to happen and the all we get is the -- indication on the LCD menu. I plan to write Nikon about this and I'm trying to reach the author of the "From Snapshots to Great Shots" 3100 book, a new one by Jeff Revell.

IF one does cleaning everytime the camera is turned off and then, when turned on, wow, I know sometimes I turn the camera off and on quite often, depending on the shooting situation. Isn't that awfully hard on the circuitry and the low pass filter on the sensor?

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

            
nikon3100 Registered since 14th Dec 2010Thu 13-Jan-11 11:07 AM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#5. "RE: Automatic sensor cleaning settings"
In response to Reply # 4
Thu 13-Jan-11 11:09 AM by nikon3100

PT
          

Hmmm, Now you have me doubting if it does work. I'll e-mail Nikon too to find out.

EDIT: Actually I just tried a manual clean and didn't hear or feel any vibration. I put the camera body to my ear and still it was silent when doing a manual clean.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                
Wordchipper Registered since 12th Jan 2011Thu 13-Jan-11 12:49 PM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#7. "RE: Automatic sensor cleaning settings"
In response to Reply # 5


US
          

>Hmmm, Now you have me doubting if it does work. I'll e-mail
>Nikon too to find out.
>
>EDIT: Actually I just tried a manual clean and didn't hear or
>feel any vibration. I put the camera body to my ear and still
>it was silent when doing a manual clean.


When I do the manual selection ("Clean now") I get a clear message across the LCD that cleaning is happening and I feel the camera doing something mechanical. Thanks for contacting Nikon too...I haven't heard back so far. This should be in the printed "get started" type booklet AND, for sure, in the Reference Manual. Also, it would be great if some of the purchased books would deal with it. The two books I've looked at, including the Dummies offering, recommend the "every off AND on." They indicate that's the factory default...I question that. Need to re-look on that point.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                    
nikon3100 Registered since 14th Dec 2010Thu 13-Jan-11 01:54 PM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#8. "RE: Automatic sensor cleaning settings"
In response to Reply # 7
Thu 13-Jan-11 01:56 PM by nikon3100

PT
          

This is the reply I got back from Nikon. I said that I don't see any notification that the sensor cleaning takes place when set to auto clean and that I don't hear or feel any vibration that any cleaning takes place whether automatic or manual.

Nikon's reply below:
Thank you for contacting Nikon technical support regarding your query.

There should not be any audible sound or vibration from the camera during the sensor cleaning as the vibration is so fine that it would not produce any sound. This is normal function for the camera.

If you have any further queries regarding this matter, please click the link above to update your question.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                        
Wordchipper Registered since 12th Jan 2011Thu 13-Jan-11 03:51 PM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#9. "RE: Automatic sensor cleaning settings"
In response to Reply # 8


US
          

Wow, "Nikon3100," assume that's your handle...THANKS for passing on the report from Nikon.

Now, the question is and if I get the answer too, I'll let you know: why is there NO INDICATION on the menu that one has made a selection other than the default? Just the two hypens --

Also...if you select "clean now" I get an indication in the LCD that the sensor is being cleaned...a text indication across the screen. However, in doing that now, there is no "vibration." But, the process does consume about 2 or 3 seconds. This doesn't happen when turning the camera off and on.

And the other part of inquiry - because I don't want to needlessly damage the camera over its lifetime - is can it be good for the circuitry to do it at every turn on and every turn off? Love to hear Nikon's view on that.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                            
nikon3100 Registered since 14th Dec 2010Thu 13-Jan-11 03:54 PM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#10. "RE: Automatic sensor cleaning settings"
In response to Reply # 9


PT
          

I've gone back to them with exactly those questions. Will let you know.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                
jpFoto Registered since 25th Jun 2010Thu 13-Jan-11 06:17 PM
1114 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#11. "RE: Automatic sensor cleaning settings"
In response to Reply # 10


US
          

I have tried the same thing with my D700, and the results are basically the same. There is no visible indication of cleaning in the "on and off" mode. However, there is a barely audible noise with both the "clean now" and when turned "on and off." That being said, the D3100 is an almost 2 year newer design. So, unless you uncover anything with your inquiries to Nikon, I think that we may be needlessly concerned.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                    
Wordchipper Registered since 12th Jan 2011Thu 13-Jan-11 10:31 PM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#12. "RE: Automatic sensor cleaning settings"
In response to Reply # 11


US
          

Will let you know what I find out too...I agree we may be needlessly concerned here. However, you know how it is with a new camera, moving up from the D40-X....and I wanted sensor cleaning on that one...but I want to do it right. After about six months with the camera, I'll probably forget about being so annal about this.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                        
nikon3100 Registered since 14th Dec 2010Fri 14-Jan-11 09:07 AM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#13. "RE: Automatic sensor cleaning settings"
In response to Reply # 12
Fri 14-Jan-11 09:17 AM by nikon3100

PT
          

OK, I got another answer from Nikon. Nice to see that they're forwarding my suggestion of providing some form of indication of what cleaning cycle has been set rather than the --. They could use the same icons they use when at the "Clean at" part of the setting.

Also of note is the part where they say the cleaning may be temporarily disabled if it's being performed several times in succession.

Nikon's reply
Thank you for your feedback. I have taken note of your suggestions and I have passed them to the design and quality department in Japan. Hopefully they will take your suggestions into account although this will be at their discretion and dependent on the number of similar suggestions from other customers.

As I stated previously there is no audible indication that the sensor is being cleaned as the technology involved creates micro vibrations in the low pass filter. This is normal function for the camera. If sensor cleaning is performed several times in succession however image sensor cleaning may be temporarily disabled to protect the camera's internal circuitry.


EDIT: Forgot to say, that if you want to have the cleaning cycle setting notification improved then send a letter to Nikon. the more requests they get the more likely something will be done about it. I use their on-line support form and always get a reply within a few hours.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                            
Wordchipper Registered since 12th Jan 2011Fri 14-Jan-11 09:56 PM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#14. "RE: Automatic sensor cleaning settings"
In response to Reply # 13


US
          

Really appreciate you're contacting Nikon on this - he doesn't deal with a couple of issues, however:

1. There is an LCD display indicating cleaning is going on now when one selects "clean now." This doesn't happen with the on and off choice.

2. I can understand not showing the LCD message with the on and off cycle but why doesn't the LCD menu indicate that the "on and off" or "on or off" cycles, that one's choice there is ACCEPTED by the camera?

Really appreciate your work on this..thanks...Wordchipper

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                            
nikon3100 Registered since 14th Dec 2010Mon 17-Jan-11 08:00 AM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#15. "RE: Automatic sensor cleaning settings"
In response to Reply # 14


PT
          

1. I assume they don't show the cleaning messages as the cleaning is done automatically so no need to delay the start up of the camera by showing the message. I personally don't mind not seeing that every time I turn the camera on or off as long as it's doing the job.

2. They addressed this in the first part of their answer. The LCD does indicate what cleaning setting you've chosen, only it shows it in the second level of the menu not the top level. It seems that is how it's been programmed in the firmware. In my e-mail to them, I suggested they change the firmware to show what auto cleaning cycle has been selected in the top level of the setting menu. I suggested they show the same little icon as shown on the second level menu. It's that suggestion that they said they'll put forward to their designers in Japan. They also say that it'll be at their discretion on the number of other similar suggestions they get from other users as to whether they change will be considered.

So this is our chance to make a change happen by submitting our requests to Nikon.

I have to say I've been very impressed at the speed of their responses to my queries. The way I contacted Nikon was through their web site. I registered my product and then used the support form. Incidentally, you don't need to use the site from the country you're resident or purchased the camera in if that's not your first language. I deal with the UK site even though I purchased the camera and live in Portugal. So contact Nikon and suggest the improvement to their menu for the next firmware upgrade. It can only help.

PS. When I refer to top level menu I am referring to the Orange menu>Clean Image Sensor.
The second level menu is Orange menu>Clean Image Sensor>Clean at.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                            
Wordchipper Registered since 12th Jan 2011Mon 17-Jan-11 03:22 PM
7 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#16. "RE: Automatic sensor cleaning settings"
In response to Reply # 15


US
          

I appreciate your answers and your contacting Nikon. I have contacted Nikon too - and have been impressed by the quickness, but not the thoroughness of the responses.

I appreciate your interpreting the answers they gave; I missed some of that understanding.

A couple questions I still have in: what is Nikon's RECOMMENDATION on Sensor Cleaning. Instead of answering that, I received a PDF that described what the sensor is on the 300 and 90...without any comment on what's best...in terms of "over doing" it, etc.

Also, on an unrelated subject, I asked why they dropped the wireless remote on the D3100? I also asked about why the battery in the D3100 is not as durable as the battery in the D40x. Instead of putitng the same "size" battery in the D3100 as the D40x, they diminished the size and the power. At the same time, Nikon says, "the battery doesn't last as long because there are increased power demands from the camera." Go figure. Doesn't make sense to me.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

                                            
nikon3100 Registered since 14th Dec 2010Mon 17-Jan-11 04:16 PM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#17. "RE: Automatic sensor cleaning settings"
In response to Reply # 16
Mon 17-Jan-11 04:16 PM by nikon3100

PT
          

I never thought to ask about their recommendation, only if having it clean during on / off could be detrimental to the circuit or sensor, especially when I can be turning the camera on and off quite frequently. Their answer was that it would temporarily disable the cleaning cycle to protect the circuit.

I guess we need to be pragmatic and give the designers some credit. After all the camera comes with the cleaning set to clean at on/off by default. Surely if excessive cleaning causes a problem that that would not have been the default. Who knows?

Is the D3100 the first Nikon to have this setting? I'm sure it isn't. If not then what are the other models doing and how are their sensors holding up?

Perhaps a better approach would be to turn cleaning off and only run a manual clean immediately after a lens change.

This is my first Nikon, in fact my first slr, so I have no experience with other models and batteries. I did think that this battery seemed to run down fairly quickly at first but after a few recharge cycles the battery life has improved quite a bit. This is normal for rechargeable batteries. But as you say, if this camera has increased power demands then why reduce the capacity of the battery?

I haven't been out on a full day of shooting yet so don't know how long the battery will last in the field but I'm going to give it a try and find out. I am expecting I'll need to be buying a spare battery before long.

___________________________________________

D3100 with 18-55mm kit lens + 55-200mm Zoom

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

            
jpFoto Registered since 25th Jun 2010Thu 13-Jan-11 12:26 PM
1114 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#6. "RE: Automatic sensor cleaning settings"
In response to Reply # 4
Thu 13-Jan-11 12:53 PM by jpFoto

US
          

>IF one does cleaning everytime the camera is turned off and then, when turned on, wow, I know sometimes I turn the camera off and on quite often, depending on the shooting situation. Isn't that awfully hard on the circuitry and the low pass filter on the sensor?

I have always felt that way, so I only do manual cleans. But, I think that it depends on what type of shooting you do and what environmental conditions exist. If you are shooting in dusty conditions, or if you do a lot of lens changes, then maybe it's good to clean at on and off.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #3120 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.