Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby MASTER YOUR TOOLS - Hardware & Software Nikon Speedlights & Lighting topic #61663
View in linear mode

Subject: "SB900 is overheating quickly after received from Nikon ..." Previous topic | Next topic
dspvisuals Registered since 24th Apr 2013Mon 17-Jun-13 10:10 AM
66 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"SB900 is overheating quickly after received from Nikon repair"


US
          

I had posted previously about this particular strobe exploding after turning it one and firing a test shot.
I sent it into Nikon for repair. After receiving it and using it the first couple times it is overheating very quickly- I have done a factory reset and turned off the warning. But within a couple minutes or say 10 exposures, and this is not rapid fire, it over heats.

I am going to call Nikon- but wonder if anyone here has any advice as to what is going on or the problem

Also- it does have the latest firmware installed.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic
Subject Author Message Date ID
Reply message RE: SB900 is overheating quickly after received from Ni...
DinoCardelli
17th Jun 2013
1
Reply message RE: SB900 is overheating quickly after received from Ni...
luckyphoto Silver Member
17th Jun 2013
2
Reply message RE: SB900 is overheating quickly after received from Ni...
dspvisuals
17th Jun 2013
3
Reply message RE: SB900 is overheating quickly after received from Ni...
MEMcD Moderator
17th Jun 2013
4
Reply message RE: SB900 is overheating quickly after received from Ni...
DinoCardelli
22nd Jun 2013
5

DinoCardelli Registered since 19th Oct 2010Mon 17-Jun-13 10:34 AM
236 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "RE: SB900 is overheating quickly after received from Nikon repair"
In response to Reply # 0
Mon 17-Jun-13 10:35 AM by DinoCardelli

Plantation, US
          

>I had posted previously about this particular strobe
>exploding after turning it one and firing a test shot.
>I sent it into Nikon for repair. After receiving it and using
>it the first couple times it is overheating very quickly- I
>have done a factory reset and turned off the warning. But
>within a couple minutes or say 10 exposures, and this is not
>rapid fire, it over heats.
>
>I am going to call Nikon- but wonder if anyone here has any
>advice as to what is going on or the problem
>
>Also- it does have the latest firmware installed.

Sounds like a problem again..unfortunately...

I have a SB900 which will overheat after about 15-20 rapid fire at 100%. power... My SB910 will do the same if at full power (sometimes but requires about 25-30 shots)...I bought the external battery packs and it seems to have helped solve the problem......now I can shoot about 30-45 rapid fire without an over heat.

The SB900, unfortunately has been a bad apple for many from the start...

dc

Visit my professional gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

luckyphoto Silver Member Nikonian since 27th Dec 2010Mon 17-Jun-13 01:09 PM
789 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#2. "RE: SB900 is overheating quickly after received from Nikon repair"
In response to Reply # 0


Port Charlotte, US
          

Some quick questions. How are you mounting it? On the camera or possibly on a metal shoe where the contracts could be shorting out or something? How are you currently triggering it? 3rd party trigger? Can you test it off the camera (not connected to anything) using CLS?

It could be multiple issues. You should focus on getting Nikon to repair it correctly. They have a warranty on the repair and have an obligation to fix it properly for you.

Larry

"Red is gray and yellow white, but we decide which is right
....and which is an illusion"

Moody Blues - Nights in White Satin

Visit my Nikonians gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
dspvisuals Registered since 24th Apr 2013Mon 17-Jun-13 01:12 PM
66 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#3. "RE: SB900 is overheating quickly after received from Nikon repair"
In response to Reply # 2


US
          

I have mounted it directly on the camera and mounted it off-camera w/ Pocket Wizard TT5 and getting same results.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

MEMcD Moderator In depth knowledge in various areas Nikonian since 24th Dec 2007Mon 17-Jun-13 02:30 PM
26394 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#4. "RE: SB900 is overheating quickly after received from Nikon repair"
In response to Reply # 0


US
          

Hi Doug,

Sorry to hear about your problem.

What type of batteries are you using?

If you have an older set of NiMh rechargeable batteries with very high internal resistance, the batteries or even a single cell could produce enough heat to be the root cause of your problem.
How hot are the batteries when the SB-900 goes into thermal protection mode?

Best Regards,
Marty

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
DinoCardelli Registered since 19th Oct 2010Sat 22-Jun-13 01:03 AM
236 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#5. "RE: SB900 is overheating quickly after received from Nikon repair"
In response to Reply # 4


Plantation, US
          

>Hi Doug,
>
>Sorry to hear about your problem.
>
>What type of batteries are you using?
>
>If you have an older set of NiMh rechargeable batteries with
>very high internal resistance, the batteries or even a single
>cell could produce enough heat to be the root cause of your
>problem.
>How hot are the batteries when the SB-900 goes into thermal
>protection mode?

Good point..I use the high capacity 2000's (Black Sanyo's) inside the flash and I used the standard 1500 Enelooop's in my battery back...seems to help.


dc

Visit my professional gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Forums Lobby MASTER YOUR TOOLS - Hardware & Software Nikon Speedlights & Lighting topic #61663 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.