Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Pocket Wizards Plus II


Jackson, US
716 posts

Click to send email to this author Click to send private message to this author
M_Jackson Silver Member Nikonian since 28th Oct 2005
Fri 05-Apr-13 08:30 PM

I have a pair of Pocket Wizard Plus II transceivers I use mainly for remotely triggering a D4 or D800. One is set up next to the camera and mounted with a RRS QR clamp and connected to the camera's 10 pin socket with the special PW cable. I believe it was designed to keep the triggering active at all times. The cable has a small inline toggle switch. I don't remember the number on the cable right off.

Everything seems to be working, but I have a few folloup questions that maybe someone here can help me understand.

The inline switch has a "hyphen" on one end of the switch and a circle on the other. When I want to review images already taken, I switch the toggle to the circle. Sometimes, I can go ahead and take a few shots while it is still switched to the circle, but if I wait more than maybe a minute, the remote will not trigger it. I have to walk back to the camera to change the toggle back to the hyphen side of the switch. I assume this is the normal scenario with this setup?

With the D800, when I shoot a dozen or so shots with the switch toggle to the hyphen, the review screen is black. When I switch the toggle to the circle, images march across the screen in the order they were taken, apparently being written from the buffer to the CF card. I don't see the last shot until all images are stored. If so, it looks like I might be limited to the size of the buffer at any particular time? On a D4, that'd be 70-90 shots. On a D800, more like a dozen or less (in FX)?

I've been out a few times in the past week trying to photograph myself while in the river fly fishing using the D800. I get all set up and do a few test shots, then the system stops firing after a short period. Maybe I have more than one issue going on here, too? I also have a SU800 controlling SB910 units with Radio Poppers in the middle. That part works fine.

I purchased a SMDV RFN-4s Slim Wireless Remote Shutter Cable Release off Amazon. Reviews seemed very good on it, and hopefully it will solve some of these problems. But, until it arrives, I'd love to know if I am doing everything right with these PW Plus II units.

Thanks in advance,
M. Jackson

M. Jackson
Jackson Hole, WY

Web Site:

Visit my Nikonians gallery.