Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby MASTER YOUR TOOLS - Hardware & Software Nikon Speedlights & Lighting topic #32516
View in linear mode

Subject: "Dead SB-600???" Previous topic | Next topic
adz929 Registered since 01st Dec 2006Sat 21-Jun-08 02:12 PM
39 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"Dead SB-600???"


AU
          

Greetings all!

I have two SB-600's, one of which I was using tonight to try and get some shots of my bady nephew. 90% of the time, the flash would fail to fire and the the remaining 8-9% of the time it would screw up the exposure. The remaining 1% would be spot on. I was shooting with my D200 at the time, however, I had my D70s in my bag too so I tried it and again, the same poor result. When I got home I tried my second SB-600 and it nailed the exposure every time. From this, I have concluded that it is the flash unit. I tried cleaning all contacts and resetting the flash, I even tried leaving the batteries out for 20 minutes and still it failed. I then dismounted the flash, set it to the lowest power and attempted to stobe it with the test button, again, 90% of the time it would fail to even fire, it would just click as though it had discharged, but it didn't flash. And yes, I did try several sets of batteries. Is there anything I have missed, or is this unit doomed to the trash can? I'm really angry about this as the unit is a little over two years old and has hardly seen any use. Any help or advice would be greatly appreciated.

Cheers,

Adam

--------------------------

adz929...The protanomolous photographer...

This post brought to you by the insane ramblings of me...

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic

Socrates Silver Member Nikonian since 01st Apr 2008Sat 21-Jun-08 03:27 PM
760 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "Deleted stupid response!"
In response to Reply # 0
Sat 21-Jun-08 03:29 PM by Socrates

US
          

,

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Forums Lobby MASTER YOUR TOOLS - Hardware & Software Nikon Speedlights & Lighting topic #32516 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.