nikonians

Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

| |

Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
Go to a  "printer friendly" view of this message which allow an easy print Print Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby MASTER YOUR NIKON CAMERA Nikon D60/D50/D40 (Public) topic #44516
View in linear mode

Subject: "D50 BODY POSSIBLY PLAYING UP?" Previous topic | Next topic
casacristeva   ES  Registered since 08th Dec 2012 Sun 10-Mar-13 07:56 AM
5 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"D50 BODY POSSIBLY PLAYING UP?"



Hi,

I am experiencing a problem whereby in auto focus, suddenly the F stop reading will not happen......

If I move the lens body then it seems to make contact again, but am having to do that more and more....... does it mean the lens could be losing its lock or the body losing its connection?

wife says I can upgrade but if this is simple then other things need to happen first!

many thanks and best wishes

Steve
Spain

  

Alert Print | Reply | Quote | Top

Replies to this topic

MEMcD Moderator In depth knowledge in various areas   US  Nikonian since 24th Dec 2007 Sun 10-Mar-13 03:46 PM
27450 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "RE: D50 BODY POSSIBLY PLAYING UP?"
In response to Reply # 0



Hi Steve,

Is the lens fully seated and locked in the mount?

Is there excessive movement between the lens and the camera body or in the lens barrel itself?

Inspect the electrical contacts on the lens and make sure they all project out the same distance. They are spring loaded and can get jammed in.

Have you tried cleaning the electrical contacts on both the lens and camera body?

Good Luck and Enjoy your Nikons!

Best Regards,
Marty

  

Alert Print | Reply | Quote | Top

    
guitarbts Silver Member  Charlotte, US  Nikonian since 24th Jan 2013 Mon 25-Mar-13 11:48 PM
28 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#2. "RE: D50 BODY POSSIBLY PLAYING UP?"
In response to Reply # 1



Steve,

I also have had the same problem. All of the sudden the shutter won't release and you look and it reads F---
Am I correct?
I have found on my D50 , the seat from the lens to the body is not tight. My D7000 works perfectly. Not sure but could be a design defect. I have often wondered if anyone else had this similar problem. I am interested in any and all thoughts on this.

  

Alert Print | Reply | Quote | Top

        
MEMcD Moderator In depth knowledge in various areas   US  Nikonian since 24th Dec 2007 Tue 26-Mar-13 02:16 AM
27450 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#3. "RE: D50 BODY POSSIBLY PLAYING UP?"
In response to Reply # 2



Hi Tom,

F-- indicates that there is no lens attached to the camera.
The usual cause are the lens is not fully seated in the mount or oxidized electrical contacts on the body, lens, or both.

Best Regards,
Marty

  

Alert Print | Reply | Quote | Top

Forums Lobby MASTER YOUR NIKON CAMERA Nikon D60/D50/D40 (Public) topic #44516 Previous topic | Next topic