Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.

Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Los Alamos, US
80 posts

Click to send email to this author Click to send private message to this author
karma1248 Registered since 10th Sep 2012
Tue 02-Oct-12 08:17 PM | edited Tue 02-Oct-12 08:26 PM by karma1248

HI All,

I hope this is the proper forum to post this request. I didn't find any forum where this really fit.

Well, I just received my new to me D2XS and I'm in the process of checking it out. All was going very well until now. I have the latest version of Camera Control 2. It's been tested with my D2H's and D70. It worked properly.

So as part of the checkout procedure I hooked up the new camera to my computer with the proper USB cable (the one that worked with the other cameras). I started Camera Control and it came up with the "No Camera was detected" message on its control panel as expected. I then turned on the camera, Windows responded with its little "I see you" gong meaning it recognized that a USB device had just been connected. Windows knows the camera (or some USB device) is there. I expected to see an indication that Camera Control recognized the D2XS with a note on its control panel as it would normally do.

But nothing happened. It behaves like the camera is not present. I tried different turn on and connection sequences. No help at all. I reconnected my D2H and D70 and Camera Control acted normally.

Whatever is happening seems to be associated strictly with the D2XS.

BTW, I was able to transfer photo files to Capture NX from the D2XS. This probably means the USB interface is working.

So, I ask if any of you have run into something like this. Is a driver involved? Usually if Windows needs a driver it goes out and finds one if it can.

Thanks for your help.


Visit my Nikonians gallery.