nikonians

Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.


Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
RJLOMMD

Owings Mills, US
258 posts

Click to send email to this author Click to send private message to this author

"Has my SB600 died?"

RJLOMMD Gold Member Donor Ribbon awarded for his generous support to the Fundraising Campaign 2014 Nikonian since 06th Jul 2004
Thu 22-Nov-12 07:42 PM

I just checked my SB600 and it would not turn on. I haven't been using it much lately--using my SB800 instead. But the SB600 did see some use last week and it was working. Naturally I looked at the batteries. I did notice that one (regular alkaline) battery had leaked a little bit. Just enough to leave some whitish residue at the top and on the cover contact.

After cleaning it up with a soft brush, I replaced the batteries with 4 Eneloops (white), but still nothing. Just to be sure, I took the 4 Eneloops from my SB800 --which I know is working fine-- and put them in the SB600. Still nothing.

Any ideas on what may have happened?? I'd appreciate any assistance or advice. But, of course, I can wait until tomorrow as I suspect quite a few us us Nikonians will be busy digesting Turkey today rather than talking Turkey!

May all Nikonians enjoy and give thanks.

R.J.L
Owings Mills, MD

Nikonians Gallery
Picasa Gallery
PBase Gallery

----------------------
enjoying many years "playing through the viewfinder"...but now getting more serious about making quality images.

A topic tagged as having a question Has my SB600 died? [View all] , RJLOMMD Gold Member Donor Ribbon awarded for his generous support to the Fundraising Campaign 2014 , Thu 22-Nov-12 07:42 PM
Subject
ID
Reply message RE: Has my SB600 died?
1
Reply message RE: Has my SB600 died?
5
Reply message RE: Has my SB600 died?
2
Reply message RE: Has my SB600 died?
3
Reply message RE: Has my SB600 died?
4