nikonians

Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.


Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising
RodW

AU
116 posts

Click to send email to this author Click to send private message to this author

"RE: Dust on sensor...."

RodW Registered since 25th Mar 2012
Mon 07-May-12 09:09 AM

I just bought a sensor clean kit to clean my D40 in the last week. It was the first clean and the camera has done about 10000 shots. It really was quite bad. I put it down to buying a few more lenses in the last 12 months so I am changing lenses a lot more. Also a 4 week caravan trip into our Aussie outback last year did not help as red dust gets everywhere.

I am not sure if that helps you though!

I think you probably have a build up of dust floating around in the body so maybe you need to vacuum it out. This dust is falling back onto the sensor.The kit I bought had a little vacuum cleaner that came with it for this purpose.

Rod W
Brisbane, QLD, Australia

A topic tagged as having a question Dust on sensor.... [View all] , Paul94583 , Mon 07-May-12 01:15 AM
Subject
ID
Reply message RE: Dust on sensor....
1
Reply message RE: Dust on sensor....
4
     Reply message RE: Dust on sensor....
5
          Reply message RE: Dust on sensor....
6
Reply message RE: Dust on sensor....
2
Reply message RE: Dust on sensor....
3
     Reply message RE: Dust on sensor....
7
Reply message RE: Dust on sensor....
8
Reply message RE: Dust on sensor....
9
     Reply message RE: Dust on sensor....
10
          Reply message RE: Dust on sensor....
11